Image Renderer plugin uses Localhost rather than defined domain

Grafana 7.0 on Windows
Image Renderer 2.0.0

This might be user error, but my renderer plugin keeps trying to use https://localhost:3000 rather than mydomainnamehere:3000

This results in a certificate name mismatch. I am pretty sure my config files are correct, as the “Share Panel” function in grafana shows the correct domain name.

Here are the logs entries i have (I had to pull the scheme from the links because discourse wont let me create a post with more than two links)

t=2020-05-21T14:04:27-0500 lvl=info msg=Rendering logger=rendering renderer=plugin path=“d-solo/2s5AeqgMz/adfs-dashboard?orgId=1&from=1590065403745&to=1590087003745&panelId=4&width=1000&height=500&tz=America%2FChicago”
t=2020-05-21T14:04:27-0500 lvl=dbug msg=“Calling renderer plugin” logger=rendering renderer=plugin req="url:“localhost:3000/d-solo/2s5AeqgMz/adfs-dashboard?orgId=1&from=1590065403745&to=1590087003745&panelId=4&width=1000&height=500&tz=America%2FChicago&render=1” width:1000 height:500 deviceScaleFactor:1 filePath:“C:\\Program Files\\GrafanaLabs\\grafana\\data\\png\\Ay6FLmnoZZ8UhTL9uFhO.png” renderKey:“6y3SJYFNVsobIh7dV7f5YqU4QbJ7YFEg” domain:“localhost” timeout:60 timezone:“America/Chicago” headers:<key:“Accept-Language” value:<values:“en-US,en;q=0.9” > > "
t=2020-05-21T14:04:28-0500 lvl=eror msg=“Browser request failed” logger=plugins.backend pluginId=grafana-image-renderer url=“localhost:3000/d-solo/2s5AeqgMz/adfs-dashboard?orgId=1&from=1590065403745&to=1590087003745&panelId=4&width=1000&height=500&tz=America%2FChicago&render=1” method=GET failure=net::ERR_CERT_COMMON_NAME_INVALID
t=2020-05-21T14:04:28-0500 lvl=eror msg=“Render request failed” logger=plugins.backend pluginId=grafana-image-renderer url=“localhost:3000/d-solo/2s5AeqgMz/adfs-dashboard?orgId=1&from=1590065403745&to=1590087003745&panelId=4&width=1000&height=500&tz=America%2FChicago&render=1” error=“Error: net::ERR_CERT_COMMON_NAME_INVALID at https://localhost:3000/d-solo/2s5AeqgMz/adfs-dashboard?orgId=1&from=1590065403745&to=1590087003745&panelId=4&width=1000&height=500&tz=America%2FChicago&render=1
t=2020-05-21T14:04:28-0500 lvl=eror msg=“Rendering failed.” logger=context userId=3 orgId=1 uname=JohnDaley error=“Rendering failed: Error: net::ERR_CERT_COMMON_NAME_INVALID at localhost:3000/d-solo/2s5AeqgMz/adfs-dashboard?orgId=1&from=1590065403745&to=1590087003745&panelId=4&width=1000&height=500&tz=America%2FChicago&render=1”
t=2020-05-21T14:04:28-0500 lvl=eror msg=“Request Completed” logger=context userId=3 orgId=1 uname=JohnDaley method=GET path=/render/d-solo/2s5AeqgMz/adfs-dashboard status=500 remote_addr=10.1.56.66 time_ms=450 size=1723 referer=“winmgmt:3000/d/2s5AeqgMz/adfs-dashboard?orgId=1”

1 Like

I was having the same problem. Try setting the following in /etc/grafana/grafana.ini:

[plugin.grafana-image-renderer]
rendering_ignore_https_errors = true

That worked for my setup using Grafana 7.0 and Image Renderer 2.0.

This helps! Thank you!

Its nice to know i’m not the only one seeing this. Ideally - and im sure you’d agree - the image renderer plugin didnt use localhost, but this is a good workaround.

I nearly submitted a bug report insisting this is a kludge, but I backed off. It is all comms local to the host, so I’m not too bothered by it. If you set up a stand-alone render node it will be able to be configured for proper HTTPS.

1 Like