**If you're seeing this Grafana has failed to load its application files**

Hosted grafana is not working for me the last hour or so, it’s very slow, does not load graphs and now it says:

If you’re seeing this Grafana has failed to load its application files

  1. This could be caused by your reverse proxy settings.

  2. If you host grafana under subpath make sure your grafana.ini root_path setting includes subpath

  3. If you have a local dev build make sure you build frontend using: npm run dev, npm run watch, or npm run build

  4. Sometimes restarting grafana-server can help

Accordign to https://grafanalabs.statuspage.io/ everything is running as it should.
Anyone else getting this?

Could have been some random Azure Kubernetes Service glitch. Your instance seems to be up and working currently.

Still, to and from the last week (now-7d) :wink: I’m getting very slow graph component behaviour. It’s loading (the buffering wheel spins) but nothing is shown. I’m not getting any error messages in the graphs, it just sits there trying to load… Single stats load a bit faster but also more slowly when this happens. Right now for example.

It looks like this:slow

My DB is MySQL running on Google Cloud, so bandwidth wise there should be no issues.

I just tried restarting my Google Cloud MySQL instance, but the problem remains.
Is there a way for the end user to see back end activity?

Please use chrome developer tools and network tab and check what happens. You can also extract a HAR and attach, if possible, or sent to me in DM.

It seems at around 19 cet my connection count to the database spiked, causing 1004 error, too many connections.

Is it correct understood that you’re using your Google Cloud MySQL instance as a MySQL datasource in Grafana?

With the recent Grafana v5.4 you can tailor MySQL datasource connection properties that may help you, see max open, idle, lifetime in docs. Your instance should be automatically upgraded to v5.4 eventually. Installing/upgrading a plugin will upgrade your instance to v5.4 now.

Hej Marcus

Yep, that is correct. Google Cloud MySQL is my datasoruce for hosted Grafana. I did update it yesterday as I was troubleshooting and my instance is running Grafana v5.4.0 (69c5191).

Those settings look promising, I shall give it a try!

Excellent, this seems to have done the trick. I put in some rather conservative limits and it cleared everything up. Seems i had a lot of open connections, probably idle.

Thank you for adding this functionality!

Darnit, back in slow land. I’ll send you a PM Marcus.

Getting "message:“driver: bad connection” in my query inspector, though it seems I’m getting nice arrays back with data they are not connecting correctly to the graph components? Or what does that error mean?