I cant add SQlite as datasource in Grafana when I run both application in docker

  • What Grafana version and what operating system are you using?
  • What are you trying to achieve?
    Add SQlite datasource to Grafana. Both Grafana and SQlite are running in docker through docker-compose but how do i specify the file path to the database in Grafana when both are running in docker containers?
  • How are you trying to achieve it?
    I have tried to different kind of file paths as data source in Grafana but I cant get Grafana docker container to connect to the database path. SQlite application is also running in docker through docker-compose but the containers are part of the same network inside docker.
  • What happened?
    I get error, I understand that the Grafana docker container cant reach the filesystem outside the container but how do I specify the the file path in Grafana so it can read the database files from SQlite? Do I neew to add anything in my docker-compose file to make this possible?
  • What did you expect to happen?
    That Grafana would be able to read my database files from SQlite. How do I specify the file path when running SQlite and Grafana in docker?
  • Can you copy/paste the configuration(s) that you are having problems with?
    See the pictures above.
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    I get the error “error checking db: no file exists at the file path”
  • Did you follow any online instructions? If so, what is the URL?

If I understand you question correctly, then you are running Grafana inside docker. The SQLite database you want to access, though, is not inside the docker container but on the host machine.

In such a case you would mount the file (the database itself) or the whole folder as a docker (compose) volume.