How to stop panels from refreshing when navigating from edit page to dashboard page in grafana?

I am using grafana version v9.3.2. We are pulling some data from amazon athena datasources and queries are quite large. We do not want these queries to be running automatically since there is cost associated with each time we query database. For this we have disabled the Refresh live dashboards option inside the dashboard settings. We have also enabled Hide time picker option from same set of settings. But still the dashboard refreshes when we navigate from edit panel screen to dashboard page. Is there a way this can be disabled? I want the dashboard to refresh panels only when we ask it to and not automatically. Does this have to do with configuration of grafana or version of it?

Edit - I did some digging and seems to be happening since this change TimeSrv: Don't modify refresh interval when editing panel by kaydelaney · Pull Request #51718 · grafana/grafana · GitHub

1 Like

I have the same problem. Even scrolling up and down the dashboard, will cause refreshing which is not desirable.
I want to refresh the page only if user requested it manually.

1 Like

facing same issue, If you got any solution then please share

1 Like

I am having the same problem , anyone was able to find the solution ?