How to configure the decimal separator

  • What Grafana version and what operating system are you using?
    Grafana 3.3.3
    Windows 10, German locale
    The numbers in the datasource are English locale

  • What are you trying to achieve?
    Displaying numbers correctly in a dashboard panel

  • How are you trying to achieve it?
    Finding a configuration to switch locales

  • What happened?
    Displaying values like 32.9 as 329 on x-axis

  • What did you expect to happen?
    32.9 being 32.9 or 32,9 but not take it times 10

Not sure if it works for your Grafana version, but you have to set Standard options->Unit. Set it to locale format.
Screenshot 2021-08-11 at 17.09.48

Does not change anything.