How do I log in? It's not working

This product is difficult and it does not seem to work at all. I installed it and admin/admin does not work, then I uninstalled it and tried on a new Centos 7 VM and the same thing occurs. the URL coes up ok but I can not log in. http://172.18.35.54:3000/login
I am deciding the Enterprise tool for dashboards and monitoring so I hope someone can help.
This command worked:
sudo grafana-cli admin reset-admin-password admin

Hi,

Anything in you grafana log ?

You can try to reset you admin password with the link below if you use sqlite database.

$ sudo sqlite3 /var/lib/grafana/grafana.db

sqlite> update user set password = '59acf18b94d7eb0694c61e60ce44c110c7a683ac6a8f09580d626f90f4a242000746579358d77dd9e570e83fa24faa88a8a6', salt = 'F3FAxVm33R' where login = 'admin';
sqlite> .exit

The command above update admin account with admin password.

Regards,

@meruem
Can you say why you answer is orientated to SQLite ?
I don’t see anything related to SQLite in the question. I’m trying to understand.

I thing I have a very similar problem to remotely login to my Grafana server

Grafana store by default user, dashboard, permission etc … in SQLite database.

And what about your log ?

About grafana configuration show me in the server section protocol , http_addr , http_port , domain

@meruem
Did you noticed I’m not the original poster ?
But I tried your command and …

pi@raspberrypi:~ $ sudo sqlite3 /var/lib/grafana/grafana.db
sudo: sqlite3: command not found

Sorry for disturbing the original poster’s thread, but it might also help anyway.

@hary66
No problem

In grafana.ini

[database]
type = sqlite3

That your configuration ?

Other think you can see is your port state

[root@localhost ~]# netstat -paunt | grep grafana
tcp6 0 0 :::3000 :::* LISTEN 1559/grafana-server

And what iptables -L command return ?

;type = sqlite3
;host = 127.0.0.1:3306
;name = grafana
;user = root

pi@raspberrypi:~ sudo netstat -paunt | grep grafana tcp6 0 0 :::3000 :::* LISTEN 1239/grafana-server pi@raspberrypi:~ iptables -L
iptables: Permission denied (you must be root).
pi@raspberrypi:~ $ sudo iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Sorry for the awful writting, i don’t know how to make it nicer.

@hary66
Every thinks seem to be OK

Try this command
sudo grafana-cli admin reset-admin-password admin

If it’s still not working use tail -f /var/log/grafana/grafana.log then try to connect and see your log

use this command

cd /usr/share/grafana && /usr/sbin/grafana-server --config=/etc/grafana/grafana.ini

and try to reset your password with the previous command

Thanks! This worked great. I greatly appreciate it.

It doesn’t seem to work for me !
Should the new login/password be admin/admin ?

One point I can’t understand is how can my machine manage SQLite database if it hasn’t an SQLite server running ?

Otherwise, I found this

When installing grafana, SQLite database is automatically installed. It’s the default database for store anything about grafana (user, dasboard, permission).

I think your grafana installation is broken. Try to uninstall and install grafana. Do not forget delete /var/lib/grafana folder.

And yes login/password is admin/admin.

sudo grafana-cli admin reset-admin-password admin
then restart grafana server
Admin is the username admin is the password. use capital A in username