Hide column in table in v7.0

Pre v7.0 you could hide a specific column in a table. I cant find any options in the overrides section to do this anymore. Not possible anymore or am I blind?

I think the new table panel is a backward step in a lot of ways. There seem to be some great features in the old panel that are not possible in the new panel. I would like to be proved wrong but I think the following features are now no longer possible:

The following seem to be no longer possible (or at least I have not found a way):

  • Rows per page (paging).
  • Font size.
  • Render value as link.
  • Sanitize HTML (this was one of the most powerful features for me).
  • Hide columns.

I am just using the old table panel as it fulfills all my needs, I just hope it is not discontinued in future releases.

1 Like

For anyone interested in this topic I have now logged this as an issue/feature request with the devs here:

1 Like

Apparently hiding columns should be supported via the Organize fields option in the Transform tab next to the Query tab but for me this does not work. Not sure why, pressing the Select button there just does nothing.

1 Like

Great.
This works for me, click the eye then apply under organize fields.

I found out 7.0.1 introduced a bug to transformations which is why I can’t use them. This is due to be fixed in 7.0.2 so if you are on 7.0.0 I suggest you keep that until at least 7.0.2

1 Like

So I managed to hide a specific column, but noticed when the column is hidden I can’t use the variables, they’re gone, this worked in v6.

Example:
I have one column called name and one column called lat,lon.
I want to make each cell in the name colum clickable and redirect the user to google maps showing the position by using the values from the lat,lon column. But the user has no use of seeing this colum, therefore it should be hidden.

I can’t test this myself until I install a fixed release but it does not sound good. Perhaps a bug or a case that the devs have not thought about. It’s a bit odd that the new table panel is missing so many features of the old panel.

I am only guessing it may be because using the Transform features perhaps now means that column is being eliminated and not being passed to Grafana so it cannot reference it/use it.

Exactly how are you referring to the variable? I do something similar using the old table panel where I have a src column (src of an image) returned by the query (7th column) which is hidden, but I refer to it in another column value link URL as ${__cell_7:raw} and that works perfectly in the old table panel.

Can you confirm you referring to your variables like that? Or in a different way?

I am just going to continue using the old table panel until the new table panel has the same features.

Sorry for the late reply.

Since v7 I’m using ${__data.fields[varName]}. I tried ${__cell_7} (did it this way in v6), but this is not working either.

@baarken I have only just updated to the latest nightly build so I can test this on my environment and yes it does appear that you can no longer reference variables if you hide the column using the transform. I think (hope) this is a bug/oversight so I have raised an issue with the devs here:

1 Like
  1. click Transform
  2. click Add transformation and select the Filter by name
  3. click the column which you want to disabled enter image description here

you can blid a query column with transform (by side of query tab) -> Organize fields => then hide the fields you want… the side effect is that hided fields are not available in the dataframe