[help] - points are not rendered in the correct hours of the timestamp

I’m using ubuntu 18.04 with everything updated.
The issue is the points in the graph are rendered one hour after the real datetime.

for example
in italy now the local time is 10.01
the date of the operative system and of the mysql is the same and is correct : 10.01

qa@qa-VirtualBox:~$ date
ven 14 feb 2020, 10.02.41, CET
qa@qa-VirtualBox:~$ timedatectl
                      Local time: ven 2020-02-14 10:03:57 CET
                  Universal time: ven 2020-02-14 09:03:57 UTC
                        RTC time: ven 2020-02-14 09:03:56
                       Time zone: Europe/Rome (CET, +0100)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: no
qa@qa-VirtualBox:~$ 

the entry in the mysql database are stored with the correct datetime, so for example if a entry is entered now, the datetime is 10.01

this is the dataset of data entered some hours ago

ts company coda
2020-02-14 08:45:19 nuovacsprod 67466
2020-02-14 09:00:35 nuovacsprod 67473
2020-02-14 09:15:21 nuovacsprod 67479
2020-02-14 09:30:22 nuovacsprod 67485
2020-02-14 09:45:31 nuovacsprod 67491
2020-02-14 10:00:27 nuovacsprod 67500
2020-02-14 10:15:36 nuovacsprod 67524

this is the query

SELECT
ts AS “time”,
coda as “da scansionare”
FROM monitoring_antivirus_ambienti
WHERE
$__timeFilter(ts) and company=’$company’
ORDER BY ts

i filter for the last hour

and i don’t see any entry (even there are entry in the last hour)

i filter for the last 3 hours

i see the first entry in 9:45:19 but it should to be 8.45.19

and the last entry are “after” the “now()” time.

if i make a LESS ZOOM

i see the last entry in 11.00.27

but now in italy is the 10.29.00

i tried changing the datetime settings for the board from

“default” to “local browser time” but nothing changed

and to “utc” time

the time was switched from utc+1 (italian time) tu utc+0 (utc time)

but the hours are shifted by 1 hour.

any help please?

thanks

Timestamps in the database must be in UTC and grafana will correct for the local timezone when it is displayed. If you put data in the db in local time you will have two samples for the same timestamp at one DST change and a gap in the data at the other.