Having issues accessing grafana locally when setup reverse proxy

I just started playing with Grafana so I am a little new at all this. I recently set up a reverse proxy using nginx. I followed the instructions for setting grafana using Nginx reverse proxy on freenas. I edited my grafana.conf file and the reverse proxy works fine. However, it doesn’t allow me to access grafana locally through the ip address. Is there a reason for this or a setting I am missing?

When you access it locally do you want it to use the proxy?
What have you got in your nginx config for the proxy (the file in sites-available)? Hide anything sensitive in there.
What IP are you trying to access it using? The local network one?