Graphs not rendering all data

I have several graphs with moderately large amounts of data on. Since upgrading to grafana 6.7 I’m finding graphs that end part way through, legends have values missing etc. If I increase the time group by the data appears, it’s as if there is some limit on the dataset size. I’m seeing this across multiple installations and graphs.

Did you also upgrade InfluxDB recently? This sounds like something to do with the InfluxDB chunking feature. Think you can turn it off and you can also turn off the max rows limit.

Yes Influx is v 1.6.4.

This is clearly the issue. I have experimented with max-row-limit and can generate {partial:True} responses in a browser, however setting 0 or 100000 fails to show the missing data. Setting fill(none) does seem to work though.

Is there a definitive fix for this, e.g. does Grafana support chunking and if so how is it enabled.

Thanks for your incisive input.

After further investigation I’m not convinced max-row-limit is the issue. Playing around with different numbers has little effect on the problem which is now mostly an inability for Grafana to display the ‘Current’ value in the legend, changing the fill to none instantly display the current value for that plot since it massively decreases the data size. It seems like Grafana can’t handle large datasets. I’ve examined the output of the data query and all looks ok, no partials and no chunks.

Hey there,

I also had the problem and found for me a rather simple solution.
My setup: Grafana 7.3.1 with InfluxDB 2.0 RC2. Using the Flux language in the current InfluxDB data source. Solution:

In the Panel Editor next to “InfluxDB” you find “Query options”. Here, the first field is “Max data points”. Increase it to get more data printed in the graph. For me, the default value has not been enough.

Another workaround: reduce the amount of data shown in the graph, e.g. by:

|> aggregateWindow(every: 30s, fn: mean)