Graph only showing a max of 10 resources

I’m trying to add more then 10 resources in my query, but it is only showing the first 10. How can I make it so it’s showing all the selected resources?

Example Query:


(Blurred part is more then 10 resources)
And the output is only 10 rows

I’m still having this issue, anyone know if it’s like a setting thats doing this? I cant find anything

Anyone? It seems like the query is limiting on 10 resources. but I havent been able to find it

Still stuck on this. Cant find any config option for this.

hi @Lemon

could you share the query making up any sensitive data?

also it’d be good to know

  • Grafana version and operating system

Grafana self hosted on Windows server 2019. Grafana version v9.4.7

{
  "datasource": {
    "type": "grafana-azure-monitor-datasource",
    "uid": "REDACTED"
  },
  "fieldConfig": {
    "defaults": {
      "custom": {
        "drawStyle": "line",
        "lineInterpolation": "linear",
        "barAlignment": 0,
        "lineWidth": 1,
        "fillOpacity": 0,
        "gradientMode": "none",
        "spanNulls": false,
        "showPoints": "auto",
        "pointSize": 5,
        "stacking": {
          "mode": "none",
          "group": "A"
        },
        "axisPlacement": "auto",
        "axisLabel": "",
        "axisColorMode": "text",
        "scaleDistribution": {
          "type": "linear"
        },
        "axisCenteredZero": false,
        "hideFrom": {
          "tooltip": false,
          "viz": false,
          "legend": false
        },
        "thresholdsStyle": {
          "mode": "off"
        }
      },
      "color": {
        "mode": "palette-classic"
      },
      "mappings": [],
      "thresholds": {
        "mode": "absolute",
        "steps": [
          {
            "color": "green",
            "value": null
          },
          {
            "color": "red",
            "value": 80
          }
        ]
      }
    },
    "overrides": []
  },
  "gridPos": {
    "h": 16,
    "w": 16,
    "x": 8,
    "y": 1
  },
  "id": 51,
  "options": {
    "tooltip": {
      "mode": "single",
      "sort": "none"
    },
    "legend": {
      "showLegend": true,
      "displayMode": "list",
      "placement": "bottom",
      "calcs": []
    }
  },
  "pluginVersion": "9.4.7",
  "targets": [
    {
      "azureMonitor": {
        "aggregation": "Average",
        "allowedTimeGrainsMs": [
          60000,
          300000,
          900000,
          1800000,
          3600000,
          21600000,
          43200000,
          86400000
        ],
        "dimensionFilters": [],
        "metricName": "cpu_percent",
        "metricNamespace": "REDACTED",
        "region": "REDACTED",
        "resources": [
          {
            "metricNamespace": "REDACTED",
            "region": "REDACTED",
            "resourceGroup": "REDACTED",
            "resourceName": "REDACTED",
            "subscription": "REDACTED"
          }, 
		  
		  
		#  followed by 80 metricnameSpace, same as above
		  
		  
		    "timeGrain": "auto",
        "top": ""
      },
      "datasource": {
        "type": "grafana-azure-monitor-datasource",
        "uid": "REDACTED"
      },
      "queryType": "Azure Monitor",
      "refId": "A",
      "subscription": "REDACTED"
    }
  ],
  "title": "CPU Chart Databases",
  "type": "timeseries"
}```

Hi Lemon ,

Did you get any updates for this ?

I also have many VM’s however Grafana is only showing 10 VM’s, how do i get it to show all of them ?

Thanks

Same issue…

UPDATE:
I think this is because MS limits by 10 by default:

I was able to solve this by adding number bigger than 10 to the “Top” parameter below:

Hope this helps.