Graph not showing while data shows in query

Hello,

I’m trying to generate a graph from some basic data but the graph is not showing.
This is the query i’m using :

First i thought i didn’t get any data but the query inspector tells something else :

All the other things, like tables and stat or other visulatisation things work except for graphs or time series.

Anyone got an idea why?

Hi,

Did you check that the timestamps you get from your query matched the time picker choosen ?

Hope it helps.

Good Luck

Hi Wlargou,

Thanks for your reply.

could you please tell me more specific what you mean or how i check that?

Hi,

Is your dates synced with what you have in time picker( eg: try an zoom out to last year data), it may be also related to timezone.

Good Luck

hi,

Timezone is the same and i already tried zooming out :frowning:

Can you show your panel config ? Maybe you should choose the field to display


Hi,

Which version are you using btw ?

Hi,

InfluxDB shell version: 1.8.4

Grafana * v7.4.0 (c2203b9859)

I found out when using count() i get a graph but the numbers are not correct.

How about using mean function ?

You should also set the unit to percentage (field tab)

Mean() doesn’t give me any data

Did you set the unit to percentage ?

hi Wlargou,

Setting percentage also gives me nothing.
I also get an error when using mean() => “InfluxDB Error: unsupported mean iterator type: *query.stringInterruptIterator”

After some trial and error i think the problem is that the data is a string:

0:Array[1612942261000,6.50 %]

1:Array[1612942271000,3.10 %]

2:Array[1612942281000,3.10 %]

So i have to regex this out.

Hi,

Did you try to perform a transform or cast your query to have that as numeric.

Good Luck

Following code was needed to convert the string to an int. everything works now!

Thanks Wlargou.

 [[processors.regex]]
order = 1
namepass = ["snmp"]
[[processors.regex.fields]]
  key = "cpu_usage"
  pattern = "[^0-9a-zA-Z.]"
  replacement = "${1}"

  [[processors.converter]]
order = 2
[processors.converter.fields]
  float = ["cpu_usage"]
1 Like

Hi ,

Graffana is supporting oracle12c barematel database ?