Grafana V9.2.0 OSS failed to update

I always kept my Grafana on raspberry up to date but now i am stock on this.
I use the commands that is given on the download site for Ubuntu and Debian(ARMv6)
When it is downloaded and will try to unpack it gives me this error.:

$ sudo dpkg -i grafana-rpi_9.2.0_armhf.deb
(Database wordt ingelezen … 60023 bestanden en mappen momenteel geïnstalleerd.)
Uitpakken van grafana-rpi_9.2.0_armhf.deb wordt voorbereid…
Bezig met uitpakken van grafana-rpi (9.2.0) …
dpkg: fout bij verwerken van archief grafana-rpi_9.2.0_armhf.deb (–install):
poging tot overschrijven van ‘/usr/lib/systemd/system/grafana-server.service’, wat ook in pakket grafana 9.1.5 zit
dpkg-deb: fout: subproces plakken werd gedood door signaal (Gebroken pijp)
Fouten gevonden tijdens verwerken van:

Please can you help me to correct this???

welkom, waar heb je deze grafana gedownload?

Would help if you posted the errors in English

En in het Engels zo goed als dat kan.

$ sudo dpkg -i grafana-rpi_9.2.0_armhf.deb
(Reading database…60023 files and directories currently installed.)
Preparing to extract grafana-rpi_9.2.0_armhf.deb…
Extracting grafana-rpi (9.2.0)…
dpkg: Error processing archive grafana-rpi_9.2.0_armhf.deb (–install):
attempted overwrite of ‘/usr/lib/systemd/system/grafana-server.service’, which is also in package grafana 9.1.5
dpkg-deb: Error: Paste subprocess was killed by signal (Broken pipe)
Errors found while processing:

1 Like

what version are you upgrading from and is your grafana service stopped while upgrading?

I was upgrading from version 9.1.5 and i stop my grafana before update

one sure way to see if this new version is problematic in rpi, it to spin up a new 9.2.0 version of grafana separate than you current one and see if it works?

I removed grafana compleet and did a new install from from APT repository.
But when i would install grafane i get the same error…

so that probably means the new version grafana-rpi_9.2.0_armhf.deb has issues. Can you try the latest 9.2.1 and see if there is an issue there as well?

Yes i did try V9.2.0 and V9.2.1 both give me this error.
I now do a clean install debian and install .deb package v9.1.5
No problem
Update from V9.2.0 give me this error.
Also update from V9.2.1 same error
Update to V9.1.8 everything is oke.
It starts with v9.2.0 i think

I would open an issue in

I solved the problem.
First i backup my grafana.ini and grafana.db
Then i removed grafana.

sudo apt-get remove --auto-remove grafana

To install the latest OSS release:

sudo apt-get install -y apt-transport-https
sudo apt-get install -y software-properties-common wget
sudo wget -q -O /usr/share/keyrings/grafana.key
echo "deb [signed-by=/usr/share/keyrings/grafana.key] stable main" | sudo tee -a /etc/apt/sources.list.d/grafana.list
sudo apt-get update
sudo apt-get install grafana

Configure the Grafana server to start at boot:

sudo systemctl enable grafana-server.service

Copy back .ini and .db

sudo systemctl start grafana-server
sudo systemctl status grafana-server

It runs like a charm :grinning: