Grafana Queries shows no data

  • What Grafana version and what operating system are you using?
    Grafana 8.0.3
    Influxdb 2.0.6
    Linux Server

  • What are you trying to achieve?
    Getting Data displayed from Influxdb
    I try to get Data shown in Influxdb 2.0.6 displayed in grafana 8.0.3

Solved the Flux Version!

I also tried to follow this guide Use Grafana with InfluxDB OSS | InfluxDB OSS 2.0 Documentation

Which means I made a v1 Database that links to my v2 Bucket ID
influx v1 dbrp list
ID Database Bucket ID Retention Policy Default Organization ID
07bdde95ccffe000 initial 9fd40fbfcd4001b5 initital-rp true 1***d

and use InfluxQL
http://****:8086
Access Server

Custom HTTP Headers
Header: Authorization
Value: Token ****

Database initial
User top
Password ****
HTTP Method GET
“Data source is working”

Now running InflusQL I can open the Query Explore, but when I click on the dropbox for “select measurement” it is empty.
GET http://####/api/datasources/proxy/1/query?db=initial&q=SHOW MEASUREMENTS LIMIT 100&epoch=ms
gives me {“results”:[{“statement_id”:0}]}
while http://####/api/datasources/proxy/1/query?q=SHOW DATABASES
shows {“results”:[{“statement_id”:0,“series”:[{“name”:“databases”,“columns”:[“name”],“values”:[[“initial”]]}]}]}