Grafana Operator with Redhat Jaeger operator

Hi

I’m fairly new to openshift and Grafana, and i really need help with this.

In my openshift cluster i have an Jaeger operator and a Grafana operator. Im then trying to add the Jaeger as a datasource to grafana.

In the docs: Jaeger | Grafana Labs
Is only showing how to connect if you have a user for the Jaeger and then provide the credentials of that user when creating the datasource, but in my case i can’t do that.

I’m trying to connect it with tls certificate. I am using a certificate i know works because that certificate works with Opentelemetry Collector.

I’m getting the error: “Unable to load TLS certificate”
if i disable the oauth-proxy it works. It is the configuration of theTLS that im getting wrong.

The Jaeger operator is the redhat version: https://github.com/jaegertracing/jaeger-operator

Here is the yaml of my datasource:

spec:
  datasources:
    - access: proxy
      isDefault: true
      jsonData:
        timeInterval: 5s
        tlsAuthWithCACert: true
        tlsSkipVerify: false
      name: Jaeger
      secureJsonData:
        tlsCACert: >- 
          -----BEGIN CERTIFICATE-----
          the certificate
          -----END CERTIFICATE-----
      type: jaeger
      url: 'https://jaeger-query.foo.svc.cluster.local:16686'

welcome to the :grafana: community @MB1!

This post could be helpful, another user was having a similar issue that was resolved there:

Another tip, if you’re able to configure the datasource via the grafana UI, you can use the browser’s developer tools to view the provisioning request when you click save & test