Grafana-image-renderer error after update

OS = Ubuntu 20.04.6 LTS
Grafana OSS = 10.0 install apt

Hello, I have updated Grafana 8.3 to 10. Before the update, grafana-imagerenderer worked flawlessly and generated images for Telegram.

The update was performed by installing over the top via apt. Plugins update was also performed by: grafana cli plugins update-all

Grafana-imagerenderer is not working right now. I look at the logs and see:

logger=plugin.grafana-image-renderer t=2023-06-28T13:59:18.334964516+05:00 level=error msg=“plugin process exited” path=/var/lib/grafana/plugins/grafana-image-renderer/pluginstart linux_amd64 pid=1955 error=“signal: terminated”

Tell me what to do?
What other information do you need for analysis?

Never use that upgrade approach.
Do you have a backup you can revert to

English is not my native language, perhaps I expressed myself incorrectly.

I carried out the update according to the instructions, I made a backup. But it seems to me that the issue should not be solved so radically - delete the current version and install a new one.

I’m sure there are simpler solutions.

1 Like

nope definitely not that approach. but definitely this approach

spin up a dev/test/qa/staging grafana and try your changes on this dev/test/qa/staging grafana version 1st. Then when you are fully satisfied with all things in dev/test/qa/staging grafana then move on to the live version. But before doing it to the live version 1st make a backup.

friend, I am very grateful that you responded, but I am not such an advanced linux user, what exactly do I need to enter a command in the console?

what folder is current grafana installed in? in ubuntu