Grafana home path on windows

Hello,
I installed grafana into my Wokstation where I haven’t admin rights. when I run grafana server I get this message.

“Grafana-server Init Failed: Could not find config defaults, make sure homepath command line parameter is set or working directory
is homepath”

I Add the path of grafana to my windows path variable but doesn’t chage anything.

Can anyone help me please ?
Thanks

Did you try starting grafana with the --config command line argument? See http://docs.grafana.org/installation/configuration/#config-file-locations for details.

Thank you Daniellee for you help.
Yes, I succeeded this morning to run the graphana server with the -config argument.

Right now I’m suck in installing plugin, because I’m behind VPN proxy (Work laptop). i can’t even ping in cmd… any Idea ?

You can manually install plugins by copying the plugin into the data/plugins directory. But first you have to download the plugin somewhere and that is a bit trickier (we have an open issue to make this easier in the future). Do you have Grafana installed anywhere else where you can download the plugin with the CLI tool?

Thank you for the open issue.it would be very nice to have it resolved.

Yes, I did install Grafana in my home PC yesterday and I used it to install plugin via cli.

Is there a place where I can download plugin-ins manually and how make them work ?.

Thanks you for your support.

Method 3 is probably the easiest (see below).

Method 1: Download via CLI and then copy to your server

If you have downloaded the plugins that you want via the CLI, then you can just copy them from your home PC to your server. For example, if you want to copy over the Diagram panel to your server, then in the data/plugins directory find the jdbranham-diagram-panel directory and copy it into your server’s data/plugins directory. Then restart your Grafana server.

Method 2: git clone from the plugin’s GitHub Repository

Other ways to get the plugins are from their GitHub repos.

  1. The link to the plugin’s GitHub repo can be found on their Grafana.com page, in this case the link is https://grafana.com/plugins/jdbranham-diagram-panel.

  2. Just git clone them directly into your data/plugins directory. For example:

    cd data/plugins
    git clone https://github.com/jdbranham/grafana-diagram.git
    
  3. Restart your server:

    service grafana-server restart
    

Method 3: Download from the Grafana.com API

The other way to get the plugins is via the Grafana.com API:

https://grafana.com/api/plugins/<plugin id>/versions/<version number>/download

For example:

  1. Find the plugin you want to download, the plugin id can be found on the Installation Tab on the plugin’s page on Grafana.com. In this example, the plugin id is jdbranham-diagram-panel:

  2. Use the Grafana API to find the plugin using this url https://grafana.com/api/plugins/<plugin id from step 1>. For example: https://grafana.com/api/plugins/jdbranham-diagram-panel should return:

    {
      "id": 145,
      "typeId": 3,
      "typeName": "Panel",
      "typeCode": "panel",
      "slug": "jdbranham-diagram-panel",
      "name": "Diagram",
      "description": "Diagram panel for grafana",
    ...
    
  3. Find the download link:

    {
       "rel": "download",
       "href": "/plugins/jdbranham-diagram-panel/versions/1.4.0/download"
    }
    
  4. Download the plugin with https://grafana.com/api/plugins//jdbranham-diagram-panel/versions/1.4.0/download and unzip it into the Grafana Server’s data/plugins directory.

  5. Restart the Grafana Server.

Did you mean grafana-server -config? What’s next?

Do you mean to change the home path? Or what problem do you have?

According to the documentation, the config file is at “/etc/grafana/grafana.ini” and I checked and it’s there but I still can’t get it to start. I tried “grafana-server --config /etc/grafana/grafana.ini” but I’m getting " “Grafana-server Init Failed: Could not find config defaults, make sure homepath command line parameter is set or working directory is homepath”

Which Operating System are you using?

Maybe: grafana-server --config=/etc/grafana/grafana.ini --homepath=/usr/share/grafana

See this link too:

It’s Amazon Linux on EC2. That command worked thanks!