Passing to grafana a custom.ini with --config and setting a path for plugins, doesn't work

Dear Grafana community,

as stated in the title I’m starting grafana with:

grafana-server.exe --config=C:\path\to\custom.ini

while in this .ini I’m specifying a precise directory for plugins with:


plugins = C:\Monitoring\config\grafana_plugins

I then start grafana but the plugin is not available.
If I run:

server-cli.exe plugins ls

it returns:

Restart grafana after installing plugins .

and even if I started grafana after dropped the plugin in the right directory, I restarted again and it doesn’t work.
Since the plugin directory is actually there I then tried to run the following command:

grafana-cli plugins uninstall natel-discrete-panel

and it returned:

Removing plugin: plugin-name
Error: ✗ CreateFile …/data/plugins/plugin-name: The system cannot find the file specified.

thus, instead of looking the plugins path specified in the [paths] section of my custom.ini, it is looking on conf/data/default.ini.
Should the custom.ini override the default.ini as stated in the documentation? What I’m doing wrong?
Any help is appreciated :)!

Just found who:

grafana-cli.exe --pluginsDir=C:\Path\To\Pugins plugins ls


installed plugins:
pluging-name @ x.x.x

who is the correct result, however just after states:

Restart grafana after installing plugins .

while I started the service just after copied the plugin in the proper directory.
On the other hand, if I do:

grafana-cli.exe --config= C:\path\to\custom.ini plugins ls

where the plugins pathe is declaread, it returns:

Error: ✗ error: CreateFile …/data/plugins: The system cannot find the file specified.

thus it insists looking in the path declared to the default.ini file.
Despite this apparently misleading behaviour … the plugins is actually installed!
Sorry for the time you spent for reading this post, may be you could think to let grafana-cli.exe grab the proper information regard the plugins path when the configuration is passed to it thtough --config.
Thank you and regards


Despite the message before mentioned:

installed plugins:
pluging-name @ x.x.x

through the grafana web interface the plugin is not available.