Grafana has failed to load its application files - Playlist

Hi all,

I’m facing an issue trying to implement Grafana. We are a network company and use multiple Zabbix servers in our monitoring environment. We want to consolidate our data into a couple of dashboards. Hence the test for Grafana.

Dashboards, API data from Zabbix using the plugin, LDAP stuff, it all works beautifully. We are also looking to use the playlist features on our NOC clients to scroll through each dashboard on some big NOC screens.

This is where the problem begins. After scrolling through the playlist for some considerable amount of time (~3/5 hours) we get the following message:

If you're seeing this Grafana has failed to load its application files.
1. This could be caused by your reverse proxy settings.
2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath
3. If you have a local dev build make sure you build frontend using: yam start, yam start:hot, or yam build
4. Sometimes restarting grafana-server can help

The error keeps popping up when refreshing the page. However when opening the page in a new tab, or connecting in a new private window, Grafana responds correctly and presents me with the menu of dashboards.

Information about the environment:

  • Upgraded to the latest version of Grafana (although we had the same problen in 5.x) v6.1.1.
  • Upgraded to a recent version of Internet Explorer
  • The Zabbix server, Grafana server and NOC client are all in different subnets with multiple devices (firewalls, routers etc) in between. Right now the Grafana server is able to connect to the Zabbix
  • We are using Grafana with the build-in webserver, no nginx, apache or proxy stuff in between.
  • We are not using any form of DNS to reach the server
  • Grafana runs on a Redhat 7 machine with Selinux disabled

Step’s i’ve tried:

  • Enable / disable HTTPS on the Grafana server
  • Enable / disable secure cookies
  • Try multiple playlists / dashboards
  • Upgrading / downgrading Grafana
  • Different user accounts
  • Different server ports etc.
  • Logging with level Debug with router logging

Stuff that does work:

  • Dashboards work great
  • The playlist feature works (for a couple of hours)
  • The Grafana server is reachable throughout the network on the configured port (https / 443)

Stuff that i haven’t tried:

  • Checking multiple NOC clients on the same network. Right now i have access to only one client for testing purpose.
  • Running a Wireshark scan to scan individual packets.
  • Different browsers on the NOC client (i have tried this on my own workstation where i couldn’t replicate the error.)

I’ve uploaded a partial log from the Grafana server (i’ve replaced sensitive information like IP addresses and user accounts.) You can see that the server hands out valid HTTP 200 replies. After that the playlist and stream of data just seem to “stop” for some unknown reason.

Do any of you have more tips on how to approach this issue? Did any of you experience similar issues regarding this error?

Thanks in advance!

After some testing the problem still persists. However configuring dashboards with an auto refresh value of 10 seconds does work and the dashboard is now functional for more than 24 hours. It seems that the amount of web requests in a given time isn’t related to the problem.