Grafana dashboard issues

We have data in elastic from a bunch of similar nodes into elastic for garbage collection. When I try to dashboard the data in Grafana, I am seeing weird issue where it shows up the graphs for a few servers but not for all. For those it’s not working - I see this message in dashboard:

data:"{ "root_cause": [], "type": "search_phase_execution_exception", "reason": "", "phase": "fetch", "grouped": true, "failed_shards": [], "caused_by": { "type": "too_many_buckets_exception", "reason": "Trying to create too many buckets. Must be less than or equal to: [10000] but was [10001]. This limit can be set by changing the [search.max_buckets] cluster level setting.", "max_buckets": 10000 } }"
message:"Unkown elastic error response"

I’ve verified multiple times that the filebeat version used on the working vs non-working servers are identical and data is being stored in elastic just the same way.

We are at elastic v7.5.0, filebeat v7.5.

I’ve tried to increase the cluster setting to 20000, but still throws the same error replacing 10000 with 20000 and 10001 with 20001. Tried going higher, but similar result. Running out of ideas and so seeking help here…any directions pointing where the issue lies is really appreciated.

Thanks