Grafana CloudWatch - WAF Metric is not visible


#1

Dears,
i’m using Grafana v4.6.3 (commit: 7a06a47).
I’ve set WAF rule on my AWS account, and tried to trigger it.
The metric in Cloudwatch show values as you can see:

But in Grafana Dashvboard no datapoint is discoverable.

Here is my configuration:
General:

Could you please help me?


#2

Hi,

Is waf metrics custom or included per default in cloudwatch? Would suggest you to upgrade to Grafana v5.0.1 (if possible) and see if it works better since I know that there have been changes made to the cloudwatch plugin recently.

Marcus


#3

Hi Marcus,
we tried to update in Grafana 5.0.1 and behaviour is the same.
Thus, WAF cloudwatch WAF metric is a default one (created when WAF is enable).
Furthermore i have same behaviour with a custom metric (DiskSpace Utilization), where is visible on cloud watch but not on grafana.
Cloudwatch screenshot:

Grafana Screenshot


#4

AWS doc:

Metrics are grouped first by the service namespace, and then by the various dimension combinations within each namespace.

=> My guess: you need to configure the service namespace in the CloudWatch datasource configuration.


#5

If there are other things not working I would suggest you have a look at open issues at Grafana github repository and/or submit a bug report issue.

Marcus


#6

Hi sgreco2002,

I hope this is not late. I just ran into the same issue.

Here’s what I did to make it work: in Dimensions, add Region = xxxxxxxx

According to AWS document: https://docs.aws.amazon.com/waf/latest/developerguide/monitoring-cloudwatch.html

AWS WAF for Application Load Balancer can use the following dimension combinations:

  • Region, Rule, WebACL
  • Region, RuleGroup, WebACL
  • Region, Rule, RuleGroup

So it seems Region is required in dimensions.

We can also get dimensions for namespace:WAF with aws cli below:

aws cloudwatch list-metrics --namespace WAF --output json