Grafana Cloud Private Data Source Connection (PDC) - connection timeout

  • What Grafana version and what operating system are you using?
    Grafana Cloud, latest

  • What are you trying to achieve?
    I am trying to connect Grafana cloud to my local PostgreSQL instance to test it out using the PDC agent.

  • How are you trying to achieve it?
    I followed this whole guide, that is pretty straightforward: Configure Grafana private data source connect | Grafana Cloud documentation

I am running this locally, so Grafana is available from there. I tried with two different approaches

  • Docker
  • Binary
  • What happened?
    None of the two solutions tried worked. When trying to connect, the PDC agent gets a connection timeout when trying to reach the Grafana server, like it’s unavailable.

Grafana Cloud status shows that everything is operational.

For information, I am using Grafana cloud free as a trial. I do not have any error indicating that this is a paid feature anywhere either in Grafana’s UI or the PDC agent.

  • What did you expect to happen?
    Obviously, I expected the agent to connect successfully, the procedure to connect it is very straightforward.
1 Like

i/o timeout indicates network connectivity issue: e.g. firewall blocks connection, …

Well I have a PiHole at home, that I tried disabling in order to verify if it might cause the issue, and it didn’t solve the problem.

I don’t have any other firewall in place on my home network or my device.

I am facing the same issue where PDC agent is showing connected but the status is not available.