Grafana can not find bucket on user

  • I am using Grafana 8.5.2 and Ubuntu 20.04.3 LTS operating system.

  • I am trying to achieve data from InfluxDB.

  • I followed all steps one by one but I am getting an error in “not found no buckets found in the organization”. I also add custom HTTP then I am getting an error of unauthorized. So, I removed it. I also try to write ID in the organization but same error. Even I tried to change the bucket name but same error.

Error is

not found no buckets found in organization

  • I am testing any data which is captured by InfluxDB.

Grafana log:

logger=tsdb.influx_flux t=2022-05-12T03:04:33.85-0700 lvl=warn msg="Flux query failed" err="not found: no buckets found in organzation .... " query=buckets()
logger=context traceID=000000000000000000000000000 userId=1 orgID=1 uname=admin t=2022:05-12T03:04:33.85-0700 lvl=info msg="Request Completed" method=POST path=/api/ds/query status=400 remote_addr=127.0.0.1 time_ms=141 duration=141.375326ms size=209 refere=http://localhost:3000/datasource/edit/J_sei9_nk traceID=000000000000000000000000000
  • I followed this link.

How to solve this problem?

Hi @arpit8081,

I hope you can access UI of influxDB on port 8086 successfully.

Now 3 important point you need to check in grafana data source configuration is

  1. Organisation name must be same as you provided in influxDB registration you can check it from influxDB UI.(it’s case sensitive)
  2. Check your bucket name is also same as configured in influxDB UI.
  3. In API Token section create API Token having All Access with read/write and all.That token only works in grafana .

I hope you get solution.

Hi @jayshah3821,

The problem is solved now. I did not create an API Token having all access.

Thanks for your help.

1 Like