Grafana Agent (v0.39) - how to add 'query_config' block for mssql_config?

The latest version of Grafana Agent (v0.39) embedded custom metrics for MSSQL integration. I tried the below configuration with adding ‘query_config’ section in integrations_config, and then Grafana Agent Service failed to start. If I removed ‘query_config’ section, it worked.

mssql:
	enabled: true
	connect_string:  "sqlserver://<USERNAME>:<PASSWORD>@<HOST>:<PORT>"
	query_config: 
	  - metric_name: mssql_deadlocks_total 
	   type: counter 
	   help: 'Number of lock requests that resulted in a deadlock.' 
	   values: [cntr_value] 
	  query: | 
     SELECT cntr_value FROM sys.dm_os_performance_counters WITH (NOLOCK) WHERE counter_name = 'Number of Deadlocks/sec' AND instance_name = '_Total'

I just followed the doc you posted, adding ‘query_config’ block in the config file, but failed.

can you try something like this:

query_config:
collector_name: mssqlmi_clerk

	# Similar to global.min_interval, but applies to the queries defined by this collector only.
	#min_interval: 0s

	metrics:
	  #
	  # Collected from sys.dm_os_memory_clerks
	  #
	  - metric_name: mssqlmi_clerk_size_kilobytes
		type: gauge
		help: 'Memory Clerk'
		key_labels:
		  - clerk_type
		values: [size_kb]
		query_ref: mssqlmi_clerk

	queries:
	  - query_name: mssqlmi_clerk
		query: |
		  SELECT
				  mc.[type] AS [clerk_type]
				  ,SUM(mc.[pages_kb]) AS [size_kb]
		  FROM sys.[dm_os_memory_clerks] AS mc WITH (NOLOCK)
		  GROUP BY
				   mc.[type]
		  HAVING
				  SUM(mc.[pages_kb]) >= 1024
		  OPTION(RECOMPILE);