Grafana 6.0 HTML text not working (bug?)


#1

Hello everyone,

Just now i updated grafana from 5.4.3 to 6.0, but after the upgrade i noticed that my HTML text fields have gone to… text, and not the HTML i made for it. both of them are iframes and should just show other websites; one of them is as follows;

iframe src=“http://someprivatewebsite.com:someportthatiuse/something” width = 670 height = 510 >;

(couldn’t add the first “<” on the post, it made the code dissapear)

after the upgrade the iframe doesn’t work and the code just shows as text, does anyone know how to fix this or maybe even know how i can downgrade back to 5.4.3?

Best regards,


#3

Managed to fix it by installing grafana on another machine and frankenstein a new config together for the old host, it had something to do with the html sanatize, though somehow in the upgrading process the INI file for it got sort of “corrupted”


Iframe in textbox broken after upgrade
#4

Hello,

We faced the same problem after upgrade Grafana from 5.4.3 to 6.0.0
Html Code doesn’t work at TEXT Panel

Regards


#5

Dear tcifci,

If you’re using linux you can easily fix it by editing the following file:
sudo nano /usr/share/grafana/conf/defaults.ini

And changing this to true, it’s at the very bottom of the file
image

in case it’s not there (like i had), try to copy some other new defaults.ini file from somewhere else.

Best regards,


#6

Thank you very much dear marss121 …


#7

All of this is documented in the release notes:


Bigger Font Sizes
#8

Hello,

" If you have text panels with script tags they will no longer work due to a new setting that per default disallow unsanitzied HTML. Read more here about this new setting."

This was there since the release day? I read it more than a time when the update was released and I didn’t notice it before.


#9

Yes it was :slight_smile:


#10

Hi!
With the upgrade of Grafana Cloud today I experienced the same issue.
From looking in the forums, it seems there isn’t an ‘config’ file to Disable sanatize html.

Is there a different way to disable it for Grafana Cloud?