Getting rid of nodata markers

I am running Grafana 9.1.4 running with InfluxDB and am manually pushing temperature data every 4 minutes from local sensors. This is not that frequent but is sufficient for my needs since temperatures do not change rapidly.

However, recently Grafana as starting to throw all kinds of NoData markers in my graphs for this data source. I am trying to determine how I can turn them off because they are annoying. I did change the “NoData” setting to OK under alerting, but that has not helped.

Any idea how to fix this? Here is a screenshot.


I do not know where version 9.x.x settings, but version 8.x.x settings by
Alert → If no data or all values are null set state to Keep Last State

Yes, I remember that option 8. In 9, the options are “ok”, “alerting” and “error.” I thought that okay would be equivalent to keep last statte; however, it clearly is not.

It seems like a big miss that that option was removed and so I am hoping that maybe it is hidden somewhere else.