Force smaller time step in data inspector

Grafana Version



Hello everyone, I am trying to export raw data from a time series Grafana panel using Inspect > Data > Download CSV. For this I need a small time step (~5 minutes) with a large time range (~1 year).


When I increase the time range, the time step in the panel increases as well.

This is propagated into the data inspector to download the CSV.

Attempted solutions

  • I have tried to decrease the Min interval in Query Options (no effect)
  • I have tried to increase the total number of data points in Query Options. This does decrease the interval in the panel, but has no effect on the data inspector.

Any advice by anyone else that has had this problem?