Facing Issue While Embedding in Grafana Flowcharting

  • I am using the Raspbian image with the Grafana Version 8.3.3 and Flowcharting Plugin version 0.9.1

  • I was trying to modify my animation with the Flowcharting plugin(app.diagrams.net.)I have been using the Grafana Flowcharting plugin for almost a year. But, while using it for the past week, I am facing one of the issues in that, when I tried to click on “Edit in Draw.io” it redirects me to “app.diagrams.net” where we can edit our diagram. But after saving the diagram, and coming back to the Grafana interface, nothing is displayed on the screen(canvas.) Can you please guide me through this “app.diagrams.net will no more work in embed mode. Use Embed.diagrams.net”. I am unable to understand this.

  • I want you to help me out, so that I could modify my animation or make new one, and not to face that BLANK screen while coming back from the “Draw.io

Here is the list of instructions, I followed, but couldn’t fix my issue.

I’m seeing the same issue. After saving the diagram (edit) in I get a blank page

1 Like

@ktodts , yes, the blank page exactly, after saving the diagram.

Hi, I have the same problem. Has anyone managed to solve it?

Still not, looking forward to it.

Hi, I have the same problem. The solution for me is to to go in FlowCharting. Then “Edit diagram”. In embed.diagrams.net, then “export as” compressed xml. After that, put the exportet xyz.xml to the editor “Edge”. In the new Format from embeded diagrams there ist a new first line : “<?xml version="1.0" encoding="UTF-8"?>”. Delete this line and put the compressed xml to the first line. Then copy this modifed xml and put this in “Source Content” from “FlowCharting”. In the Moment you put this in the “Source Content” the diagram will be shown. I hope that will help you for the first.

Hi @volker , good to hear from you.

I have tried and followed the steps, that you mentioned in your above comment, but I couldn’t find any line containing <?xml version="1.0" encoding="UTF-8"?>, as can be seen in the attached screenshot of the Edge editor(file is downloaded from the embed.diagrams.net in the compressed .XML format). Can you help me with that?

After saving the diagram, I noticed that Draw.IO inserted two XML tags, xmlfile and diagram, to cover the original data. To resolve this issue, remove these two XML tags at the top and bottom of your XML data.


Thanks, @maetee , it works perfectly fine.

But I wanted to ask one more thing: each time I come back to Grafana from the editing mode(https://embed.diagrams.net), I have to repeat the same process again and again.

Is there a way to fix it once and then follow the same pattern, or do we have to repeat the above-mentioned steps again and again?

I have to remove the mentioned xml tags every time I edit and save my diagram. I
think the flowchartint plugin needs to be updated to reflect the Draw.io changes.


But I have the latest version of the flowcharting plugin(0.9.1). Let’s hope for the best and look forward to the solution to this repetition.

By the way, thanks a lot @maetee .

thank you, you saved my day