Error when running a test WARN[0014] Request failed unsupported protocol scheme

I’m new using k6. When I run a test, I don’t know if it is only for that specific test I run or not, but i get that error in http debug mode:

FATA[0014] unsupported protocol scheme "wss"

(running with simple ‘k6 run’ i get the error in the topic)
And i don’t have any idea of what the problem is.

Please help

Some new clarifications:

While searching for a solution I saw a request on an url starting wss:// so I though it was the problem and I changed that to ws:// but it doesn’t change i still have an error, just now it says unsupported protocol scheme \"ws\"

I have the right import at the beginning of the file and maybe it is important to precise I did the test script with an HAR file.

Hi, welcome to the forum!

How did you generate the HAR file? Did you use the built-in recorder in a web browser, and then ran k6 convert on it? Or did you use the har-to-k6 conversion tool?

This is not well documented at the moment, but there are some issues with the internal k6 convert command and it’s being planned for removal in favor of the har-to-k6 tool. So give that a try if you haven’t.

Also consider using the LoadImpact Chrome extension to record a user session directly to a k6 test script, without the need of a HAR file.

1 Like