Dual y scale - grafana 8.x

hello
i have done it with this and worked fine

since i have done a update to grafana 8x
when i click on the color line it just show the option to change the color but not to make it left or right axis - did i miss something?

have a nice day
vinc

Also taking this dashboard
https://play.grafana.org/d/YI95GyqMz/1-new-features-in-v8-0?orgId=1&editPanel=66
it is not working like describet below

your question is exactly this
maybe browse a bit before posting a new one

1 Like

i found this - but looks like to have no efects

somebody having a idea about the dual y-axis in grafan v8

good that you found them. next step is to add the override property as stated in my comment on another post

1 Like

hello @bferdinandes
did you see my picture select field selct axis and still no difference.

hello @vikozo

yes I did see your picture.
yes I did see you selected the field, and selected the axis placement.

did you read my comment in that other thread?
I said:

yes I can see your axis placement override
but I didnt see your standard options: unit override

come back again after you try it
whether fail or success

1 Like

i have 8.0.3 Grafana but i dont get this option axes Placement
Unbenannt

Axes > Placement” is another property to override
just like “Standard Options > Unit
they are on the same level

so the structure is something like this (for your sample):
Field = Temperatur
Property = Standard Options, Axes

for image below:
field = Temperature
property = Standard Options, Axis
image

sorry but i don’t have the option Axis at all! do i need a plugin or something
grafana-4

in your earlier post, you are talking about ‘Time Series’ panel
in your latest post, I can see you are using ‘Graph (Old)’ panel

my earlier posts are about ‘Time Series’ panel.

for ‘Graph (Old)’ panel,
click that legend’s color of your series


then click on the Y-Axis tab, turn ON right axes option
image

1 Like

yes you are right - i mixed up this two graph.
with timeline it works as you described.
i restarted to crate the graph and it works like you described.
just another question to have a second y left axis where do i have to put or edit to add
“Y-axis: 2”

have a nice day
vinc

which one is timeline? is it ‘Timeseries’? or is it ‘Graph (Old)’?

to have 2nd Y left axis, you need to:

  1. override a field
  2. property: standard options - unit = (put a metric here)
  3. property: axis - placement = left
1 Like

@bferdinandes , could we dig into this a bit more. I have a Time series panel. I have two series, create two overrides for Axis > Placement.


Doesn’t work.

But the funny thing is, that if I choose the same Unit (Temp C) on both overrides, or don’t do an override on Unit and keep the unit in All | Standard section, then dual Y axis doesn’t work. But if I choose a different units on both axis, then is works:


Grafana version is v8.1.2.
Any idea to explore?

Looks like a, khmm, missing feature: Time-series panel: multiple y-axis of same unit · Issue #32165 · grafana/grafana · GitHub

1 Like

For anyone finding this topic - the issue #32165 is fixed in 8.3 with

1 Like

This topic was automatically closed after 365 days. New replies are no longer allowed.