Deleted default Linux Node dashboard not creating again

What happened?
I have tried to use Linux Server monitoring via Grafana Agent. I have started the agent. The test of the agent on the Gragana Cloud site was successful. But I have accidentally deleted Linux Server monitoring dashboard. And I can’t install it again. The system does not create it automatically. How I can restore this default dashboard?

What was expected to happen?
The default Linux Server monitoring dashboard should be automatically recreated if it is absent after clicking on the “Test integration and finish installation” button on the “Install Grafana Agent for Linux Server” page.

Steps to reproduce the problem:

  1. Go to “Install Grafana Agent page”
  2. Choose Linux Server, click “Install Ingtegration”
  3. Install agent
  4. Test agent
  5. Click “Test integration and finish installation” and continue to the dashboard
  6. Remove Linux Server monitoring dashboard
  7. Repeat steps 1-5 in order to recreate the dashboard.
  8. After continuing to the dashboard (step 6) see the error that folder with the dashboard is absent. The dashboard will not be recreated.

Version numbers (grafana, prometheus, graphite, plugins, operating system, etc.):
Default versions of Grafana Cloud

Configuration information:
Agent is running on Ubuntu 20.04.

Also I have managed to use dashboard Node Exporter Full dashboard for Grafana | Grafana Labs. But is there a way to use the default dashboard? Where can I get it?

Hello, I ran into this issue myself a few weeks back. You need to remove the integration (you do not need to uninstall the agent from the machine) from the Integrations Management section of Grafana Cloud and then walk through the setup again.

Integrations Management can be reached by hovering over the Lightning Bolt menu on the left hand side of your Grafana Cloud page and selecting the second option. From there, you can select the installed integration, in this case Linux Server, and a side panel will appear allowing you to uninstall it. This seems to be an issue for all of our integrations currently and we are working to fix it.

2 Likes