Data sources configuration crashes

> Hi,
> Pretty new in that field, I'm installing Grafana v8.1.2 (103f8fa094) on rhel 7, to use it with influxdb. 
> To access grafana I use nginx with a reverse proxy. Browser is Edge.
> 
> After (many) trials and errors with configurations of influx, nginx and grafana, I have grafana running but not 100%. When I want to configure a "data sources" it returns "TypeError: e.dataSources.filter is not a function"; with additional errors like "at E (.../public/build/vendors~app.8ea303538f79ee32b68a.js:2:73696) "
> And the navigation (on edge) is not working. Meaning I can't navigate to the previous page.
> I tried to yum remove and re-install but it didn't change anything (even the admin pwd was the same... (?))
> To configure I followed this tuto: https://grafana.com/tutorials/run-grafana-behind-a-proxy/
> 
> grafana.ini:
> 
> # The public facing domain name used to access grafana from a browser
> #;domain = localhost
> domain = xxxmyserver.xx
> 
> 
> # Redirect to correct domain if host header does not match domain
> # Prevents DNS rebinding attacks
> ;enforce_domain = false
> 
> # The full public facing url you use in browser, used for redirects and emails
> # If you use reverse proxy and sub path specify full url (with sub path)
> #;root_url = %(protocol)s://%(domain)s:%(http_port)s/
> ;root_url = %(protocol)s://%(domain)s:%(http_port)s/grafana/
> 
> # Serve Grafana from subpath specified in `root_url` setting. By default it is set to `false` for compatibility reasons.
> #;serve_from_sub_path = false
> ;serve_from_sub_path = true
> 
> # Log web requests
> ;router_logging = false
> 
> # the path relative working path
> ;static_root_path = public
> 
> on nginx:
> map $http_upgrade $connection_upgrade {
>   default upgrade;
>   '' close;
> }
> 
> server {
> listen 80;
> 
> root /usr/share/nginx/html;
> index index.html index.htm;
> 
> #server_name xxxmyserver.xx www.xxxmyserver.xx;
> 
> location / {
>         #proxy_set_header Host $host;
>         #proxy_pass http://localhost:8086;
>         proxy_pass http://localhost:3000/;
>         #rewrite ^/(.*) /$1 break;
> }
> 
> location /api/live {
>         proxy_http_version 1.1;
>         proxy_set_header Upgrade $http_upgrade;
>         proxy_set_header Connection "Upgrade";
>         proxy_set_header Host $http_host;
>         proxy_pass http://localhost:3000/;
> }
> 
> #location /grafana/ {
> #       proxy_pass http://localhost:3000/;
> #       proxy_set_header Host $host;
> #       proxy_set_header X-Real-IP $remote_addr;
> #       proxy_set_header X-Forwarded-Host $host;
> #       proxy_set_header X-Forwarded-Server $host;
> #       proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
> #}
> 
> So How can I "reset" the whole setup or how can I configure data sources again (because once it worked...)
> 
> Any inputs to solve this would be welcome...
> In advance thank you

Hi @juliensorel,

Ok, so you are running Grafana on RHEL behind nginx, yes? And you can access Grafana through your browser without issues, yes? Are you running influxDB on the same instance and querying it on localhost? What does your datasource configuration look like?

Hi
All points are correct. Influx is on the same instance. It’s not possible to configure any datasource. Yielding d.filter is not a function.

can you communicate with influx using cURL? Just want to establish that communication is possible…