Dashboard hangs with message "Services"

When I try to open the affected dashboard I only see the Grafana toolbar on the left and a white screen with a “Services” message and a spinning wheel. I would expect to see the dashboard or some kind of error message that tells me what is going on.

I tried multiple times, reloading everything, restarting grafana, but the dashboard won’t load. I checked the grafana log but didn’t find any error messages in there. Other dashboards are working.

Any hints how to resolve this would be appreciated!


  • Grafana version: Grafana v6.1.6 (cf9cb45)
  • Data source type & version: PostgreSQL
  • OS Grafana is installed on: CentOS Linux release 7.6.1810 (Core)
  • User OS & Browser:
    Windows 10
    Chrome Version 74.0.3729.169 (Offizieller Build) (64-Bit)
    Firefox 67 (64-Bit)

It can be that you made a mistake with templates in that dashboard.

I did a change in my templates and now it just showing Services with a spinning wheel

I solved it, changed port for the Datasource and then I could open the dashboard and remove my error.