Copying Dashboard JSON to new Organization - "Dashboard not found"

  • What Grafana version and what operating system are you using?

Grafana v10.3.1

  • What are you trying to achieve?

Copying Dashboards between Organizations. This is in order to achieve the following:

Compartmentalized ‘perspectives’ for users in the file system i.e. User A should only see a certain set of dashboards/folders in Grafana when looking at the file hierarchy.

Managing user permissions cannot be used at this point to hide folders or dashboards from users. It can lock them out, but this is not good enough.

  • How are you trying to achieve it?

I’m copying the JSON from the dashboard I want to copy:

Then, in my new Org. “DeployTest”, I am creating a new dashboard and pasting the JSON in the JSON Model section. I have tried various edits to the JSON to make this work:

  1. Removing the uid
  2. Changing title to match current title “New dashboard”
  3. Setting “version” to values from 0-4
  4. Not editing anything

  • What happened?

Every time I click “Save changes” I get the following:


That’s all.

I have seen: Copying base dashboard to all the organizations

And have basically tried this, but it is not exact because this could have been an older grafana (I see no dashboarduid field as @svetb referenced there, in message 3, but that probably corresponds now to the outermost uid, which I tried already).

Any help is greatly appreciated. Thank you.

Hi @rob.loh

I do not have the ability to verify it now, but I am pretty sure you need to create a dummy dashboard in the new system, export it (or view) as JSON to find the new UID, then do a find/replace on the old dashboard JSON to change the old UID to the new UID. I have done this recently and it works exactly as expected.

Hi @grant2 , I forgot to mention that I tried this and it did not work. I tried it again after seeing your message, with versions 0 through 3, and the results did not change.

Edit: Just to see what happens, I also took the old uid and put it in the new json and clicked save. In that case it still says “Dashboard not found” but also says that uid was invalid.

That means the uid is at least being found when pasting it into the old dasbhoard JSON. Why does it say “Dashboard not found”? Not really sure what information that provides us with, since the uid (of the dashboard) is apparently “valid” (which I take to mean it has been found)

Just thinking out loud. You mentioned you copied it to a NEW/other organization.
Does that means you get data from another “bucket” to show data related to that organization?

I use a similar way to copy panels/full dashboard for different organizations.
But I do have to replace ‘Org. A’ with ‘Org. B’ first (I do this in notepad) to make it work.

You change Org. A to Org. B in the JSON? I see no attributes for this in my JSON…

I’m not sure what you mean by getting data from another “bucket”… I’m not showing different data, I just want the same exact dashboard to be in this new “Grafana Org”:


Some additional info.
For Organization A. I use data from their database.
So my query refers to SELECT data from ‘database A’

so if I want to create new Dashboard for Organization B.
I also have to adjust my query to SELECT data from ‘database B’

But dont know if that is the case for you as well?

No I use the same data, same database. The problem is just “Dashboard not found” when pasting the JSON and clicking save (with various edits, of course)

Ah ok.
Hmm strange. In that case it should work even easier then.

You also tried to copy JSON data into plain textfile.json and import it like that?

Update: The “id” attribute still exists. It must also be deleted.

Hadn’t seen it before: