Compiling and running Grafana using a ubi8 containers

Hi grafana team and experts,
I have developed custom themes for Grafana to match the rest of our GUIs.
In order to do this, we changed what we needed and compiled using the Dockerfile that is available on github, until this point, no problem found.
Since I need my images to be certified by RedHat and it seems that you use Alpine I started the conversion of the Dockerfile, but when we are unable to find a equivalent to the musl package.
The dockerfile is able to complete but when we try to run we always get an error that grafana is not found.

Is there anyone that was able to get either custom themes without having to recompile the source code, or run grafana in a ubi9 image after the code is compiled with some changes?

Thanks for your support,
LP

  • What Grafana version and what operating system are you using?
    Latest code in Grafana, ubi9 (Linux RedHat)

  • What are you trying to achieve?
    To compile a Grafana version with our own themes based on RedHat

  • How are you trying to achieve it?
    Changing the code to have the themes then running in RedHat

  • What happened?
    Running /run.sh failing with message: “./grafana: No such file or directory”

  • What did you expect to happen?
    I would expect it to run

  • Can you copy/paste the configuration(s) that you are having problems with?
    No configuration.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

  • Did you follow any online instructions? If so, what is the URL?
    No