Can't login to localhost:3000 with admin credentials


I am working on windows 11.
Downloaded and ran the local Grafana 2 weeks ago and managed to login with ‘admin’ user and default ‘admin’ password.
I dont remember if I switched to another user, anyway, I can’t login with admin default credentials anymore.

trying to run the “grafana-cli --homepath “/usr/share/grafana” admin reset-admin-password blahblah” but I am getting:
Grafana-server Init Failed: Could not find config defaults, make sure homepath command line parameter is set or working directory is homepath

what can I do to fix it??


welcome to the :grafana: forum, @guyber

can you confirm that /usr/share/grafana is indeed the correct homepath?

Have you tried running the command from the grafana-cli directory, just to rule that out?

thanks @mattabrams
yes, I ran the command from the grafana cli directory.
but no, I am not sure that this is the correct homeopath. how can I know what it is?

Hi, I am also facing the same problem. I have tried by uncommenting the grafana.ini user and password params but it’s still the same. I tried grafana server restart as well. Please someone help me out here ?

Try running the command:

find / -name grafana.ini -exec ls -l '{}' \;

That will tell you four things:

  1. Which directory the Grafana .ini file exists in (the “homepath”)

  2. Which user it is owned by, and what the permissions on it are

  3. The date/timestamp when it was last modified.

Those bits of information should help to narrow down the cause of the problem.