Can't connect to influxdb

Was trying to setup Grafana with Influxdb in a docker environment. Installed both with the “latest” tag. Both are accessible through their webgui. But when configuring Grafana to connect to influxdb, it just doesn’t want to connect. I got the following errors:
“Get “http://192.168.0.13:8086/query?db=hadb&epoch=ms&q=SHOW+measurements”: dial tcp 192.168.0.13:8086: i/o timeout error performing influxQL query”

In all guides I find online, I see that in the HTTP section there is a field “Acces” with setting “Server (default)”, but in my version of grafana I don’t have that field.

Eventually I have been able to solve this after finding a youtube video with github link to a docker compose file that forces the grafana version to grafana/grafana-oss:8.4.3 and influxdb:2.1.1. This combination worked right away and does have the “Access” field in the influxdb connection.

So I now do have a working config, but afraid to upgrade and still not sure why this works and the “latest” config wouldn’t.

Anyone have some insight on this? Is it correct that in the latest grafana the “access” field is no longer visible?