Can't access my interface anymore

  • What Grafana version and what operating system are you using?

    • Grafana CLI version 8.4.3

    • Debian 11

  • What are you trying to achieve?

    • Access my interface
  • What happened?

    • Error message while trying to access the interface :
If you're seeing this Grafana has failed to load its application files

1. This could be caused by your reverse proxy settings.

2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath. If not using a reverse proxy make sure to set serve_from_sub_path to true.

3. If you have a local dev build make sure you build frontend using: yarn start, yarn start:hot, or yarn build

4. Sometimes restarting grafana-server can help

5. Check if you are using a non-supported browser. For more information, refer to the list of [supported browsers](
  • What did you expect to happen?

    • My dashboard to display
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

    • I couldn’t find anything in the logs. No information at all.

I don’t understand why i can’t access my dashboard, i haven’t make any change at all in the .ini
All setting are straight from installation. Grafana was working for a while, then i reopened after few weeks of inactivity and i got this error.

Thanks a lot for your help.

@grosjambon33000 I’ve seen this before and usually a restart will resolve it if you haven’t made any other changes. Did this error persist after that?

Still the same error. I tried a restart of the grafana service and even a restart of the server itself.

@grosjambon33000 it looks like a few users have been running into this recently. There’s a github issue here. Some suggestions there are:

  • set the root_url in grafana.ini to the URL you want to use in your browser for grafana
  • set content_security_policy to false in grafana.ini to verify if that is the cause
  • there is a bug reported that some plugins can cause this error to appear incorrectly

still the same.

it was already set to false.

Is there a way i can backup my dashboard ? then reinstall grafana ?

May be it will solve the problem ?

so i managed to save my queries before completely remove grafana from my server.

So i fully uninstalled grafana from my server, then reinstall it and then when trying to access the GUI, i still got the same error message.

it’s really weird because it’s a complete fresh new install…

So now i definitely can’t use grafana at all…

@grosjambon33000 that is very strange, has anything else changed in your environment? If you’ve installed grafana as a service, what happens if you run grafana from a standalone binaries in the zip file instead of installing it as a service?

it’s a home server where i work everyday so multiple change can happen. But nothing related directly to grafana, as i’ve not used it since few weeks and back then it was working well.
So i guess another change lead to this situation. But i’ve no idea at all which modification could have done this…

i will try binaries in the zip file, but my server is headless so will it be possible to use the binaries ?

@grosjambon33000 yes, you should still be able to start grafana at the command line and then reach it with a browser from another machine on your network.

This problem seems to be solved in Grafana 8.4.4

i confirm, i’ve just receive an update that seems to solve the problem.

1 Like