Cant able to install yarn while setting local grafana

  • What Grafana version and what operating system are you using?

Grafana 10.2

  • What are you trying to achieve?

Installing grafana locally using github

  • How are you trying to achieve it?

  • What happened?
    Shows error while running yarn and yarn build

  • What did you expect to happen?
    To make run yarn and next run make grafana command

  • Can you copy/paste the configuration(s) that you are having problems with?
    yes

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

When we tried to set up a Grafana development environment in local and I tried to install yarn and yarn build. Then we faced this issue. I attached below the error message .

SyntaxError: missing ) after argument list
at wrapSafe (internal/modules/cjs/loader.js:979:16)
at Module._compile (internal/modules/cjs/loader.js:1027:27)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1092:10)
at Module.load (internal/modules/cjs/loader.js:928:32)
at Function.Module._load (internal/modules/cjs/loader.js:769:14)
at Function.executeUserEntryPoint as runMain
at internal/main/run_main_module.js:17:47

Welcome @dhamodharang

Is this a clean git clone or have you made some code changes

That’s a clean git clone ,I didn’t made changes