Failed to install Grafana from source code on Windows 11 - 64 bit

Hi, we tried to install Grafana from source codes but facing some difficulties.
we download from this source:

we follow this guidance:

steps that we run:

  1. yarn install --immutable > success
  2. yarn start > success
  3. make run > failed
    you can check the error msg on the attachment.

appreciated your help.
thanks in advance.

~ the grafana team

Hi @gutasaputra,

Welcome to the :grafana: community support forums !!

We are excited that you joined our OSS community. Please read about some of the FAQs in the community :slight_smile:

For Windows, there seems to be a separate link within the developer-guide page. Please check it out if you haven’t and then let us know.

Also, I move this post to the correct category :slight_smile:

1 Like

I am facing the same issue.
I started the yarn with yarn start.
I built the back-end with wire and

C:\Users\User\go\bin\wire.exe gen -tags oss ./pkg/server ./pkg/cmd/grafana-cli/runner
go run build.go build

I write the command

make run

on git bash, but I get the same error with bra-v0.0.0-20200517080246-1e3013ecaff8

What should I do?

Hi @anushlabs,

We would appreciate it if you can open a bug report about this in our official GitHub repository using this link.

Provide all the information (you can simply copy/paste your data + screenshot from here to there).

Lastly, paste the link to your GitHub issue here in this post so that all other community users can also track it. I will also add more additional information to it :+1: