Cannot set required precision in Stat panel

I can’t set the required precision in my Grafana Stat panel:

  • current format: €-1.012K
  • required format: €-1012.97

In the original Singlestat panel, I could circumvent this issue by using a “€” prefix but Stat doesn’t seem to offer this flexibility or any other workaround. Grafana 8.4.7

Any known workaround?

could you please post sample data coming from the data source?

moneytalks
€-1012.97?
-1012.97?

Even with latter data I was only able to set it as -1012.97 using Unit / Standard Options/Unit/Locale Format. But then you lose the euro currency.

Not sure if this is what you mean: data straight from the query inspector:

yld
-1048.38056

Obviously a different (later) value than before. The key problem is that Grafana converts the number to use thousands with the symbol “K”.

This should be rendered as €-1048.38 and not €-1.048K