Cannot See Oracle Enterprise Manager (OEM) Plugin in Add Data Source List

  • What Grafana version and what operating system are you using?
    9.1.1 on Linux 7, 64 bit

  • What are you trying to achieve?
    Integrate Grafana with Oracle OEM,

  • How are you trying to achieve it?
    Downloaded and installed Grafana Server using:
    wget …grafana-enterprise-9.1.1-1.x86_64.rpm
    sudo yum install grafana-enterprise-9.1.1-1.x86_64.rpm

Started the server
sudo systemctl enable grafana-server.service
sudo systemctl start grafana-server
sudo systemctl status grafana-server

Downloaded the OEM Plugin from Grafana Download page | Oracle
Version 3.0.0
Installed using:
grafana-cli --pluginUrl /home/oracle/GRAFANA/ plugins install oracle-emcc-app

Modified defaults.ini per enable-oracle-enterprise-manager-app-grafana.html

allow_loading_unsigned_plugins = oracle-emcc-app,oracle-emcc-datasource
*Enabled the service on OEM per the same link:

Restarted Grafana server:
sudo systemctl restart grafana-server

Checked installation of plugin:

grafana-cli plugins ls

installed plugins:
oracle-emcc-app @ 3.0.0

  • What happened?
    Logged into Grafana console:
    Click Add Data Source
    Search for Oracle OEM…

  • What did you expect to happen?
    Should see OEM as a data source.
    Cannot see it, after multiple restarts, still not seen.

  • Can you copy/paste the configuration(s) that you are having problems with?
    As above.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    No Errors

  • Did you follow any online instructions? If so, what is the URL?
    Oracle mos note 2632952.1.


Anything in the log files you could share?

Since I am a newbie, where are the logs?

Found the log.
Found a permission issue on the plugins directory. Set the owner/group to grafana.
Can see the plugins getting registered in the log now.
Had to go to configuration | plugins and enable the unsigned plugin - should be documented!
Now see it in the Data Source screen.
Closing this thread.

1 Like