Cannot edit panel on fresh install and new panel

I just made a fresh install of 6.6.2 and all was well until I made a gauge chart and that works fine.

Until I added a second panel, a gauge chart and now I cannot edit the gauge when I press the small down arrow at the top

So the only thing I can do with this panel now is to move it around or resize it.
This is what I hoped to avoid when upgrading from my ver. 6.4 that did the same thing with a bar chart.
Is this only happening and recurring with me and just my bad luck? :grimacing:

Hi!

Which browser are you using?
Can you share your dahsboard JSON or at least screenshots so we can have more details on your settings please?

It’s really weird indeed!

Thanks @agnestoulet1
et me try to make a json, I cannot make of only the panel as I cannot access the edit od the gauge chart :upside_down_face:

Ok I inlined the complete json, please let me know if you see anything interesting …

Best wishes,
Eric

{
“annotations”: {
“list”: [
{
“builtIn”: 1,
“datasource”: “-- Grafana --”,
“enable”: false,
“hide”: true,
“iconColor”: “#F2495C”,
“limit”: 100,
“name”: “Annotations & Alerts”,
“showIn”: 0,
“type”: “dashboard”
}
]
},
“editable”: true,
“gnetId”: null,
“graphTooltip”: 0,
“id”: 2,
“links”: [],
“panels”: [
{
“datasource”: “demo”,
“gridPos”: {
“h”: 11,
“w”: 12,
“x”: 0,
“y”: 0
},
“id”: 4,
“options”: {
“fieldOptions”: {
“calcs”: [
“mean”
],
“defaults”: {
“mappings”: [],
“max”: 150,
“thresholds”: {
“mode”: “absolute”,
“steps”: [
{
“color”: “green”,
“value”: null
},
{
“color”: “red”,
“value”: 80
}
]
}
},
“limit”: 250,
“overrides”: [],
“values”: true
},
“orientation”: “auto”,
“showThresholdLabels”: false,
“showThresholdMarkers”: true
},
“pluginVersion”: “6.6.2”,
“targets”: [
{
“groupBy”: [
{
“params”: [
__interval" ], "type": "time" }, { "params": [ "null" ], "type": "fill" } ], "orderByTime": "ASC", "policy": "default", "query": "SELECT last(value) from dxdata where analyte ='Insulin' and unit <> '...waiting...' ", "rawQuery": true, "refId": "A", "resultFormat": "time_series", "select": [ [ { "params": [ "value" ], "type": "field" }, { "params": [], "type": "mean" } ] ], "tags": [] } ], "timeFrom": null, "timeShift": null, "title": "Insulin Reading", "type": "gauge" }, { "datasource": "demo", "gridPos": { "h": 16, "w": 24, "x": 0, "y": 11 }, "id": 2, "interval": "", "options": {}, "pconfig": { "fixScale": "", "layout": { "dragmode": "zoom", "font": { "family": "\"Open Sans\", Helvetica, Arial, sans-serif" }, "hovermode": "closest", "legend": { "orientation": "h" }, "showlegend": true, "xaxis": { "rangemode": "normal", "showgrid": false, "type": "", "zeroline": false }, "yaxis": { "rangemode": "tozero", "showgrid": true, "title": "Insulin", "type": "", "zeroline": true }, "zaxis": { "rangemode": "normal", "showgrid": true, "type": "linear", "zeroline": false } }, "loadFromCDN": false, "settings": { "displayModeBar": true, "type": "scatter" }, "showAnnotations": false, "traces": [ { "mapping": { "color": "dxdata", "size": null, "text": null, "x": "dxdata@time", "y": "dxdata", "z": null }, "name": "Insulin", "settings": { "color_option": "ramp", "line": { "color": "#37872D", "dash": "solid", "shape": "linear", "width": 4 }, "marker": { "color": "#33B5E5", "colorscale": "YlOrRd", "line": { "color": "#DDD", "width": 0 }, "showscale": false, "size": 10, "sizemin": 3, "sizemode": "diameter", "sizeref": 0.2, "symbol": "circle" } }, "show": { "line": true, "lines": true, "markers": true } } ] }, "targets": [ { "alias": "", "groupBy": [ { "params": [ "__interval”
],
“type”: “time”
},
{
“params”: [
“null”
],
“type”: “fill”
}
],
“orderByTime”: “ASC”,
“policy”: “default”,
“query”: "SELECT value FROM “dxdata” WHERE analyte =‘Insulin’ AND unit <> ‘…waiting…’ AND $timeFilter “,
“rawQuery”: true,
“refId”: “A”,
“resultFormat”: “time_series”,
“select”: [
[
{
“params”: [
“value”
],
“type”: “field”
},
{
“params”: [],
“type”: “mean”
}
]
],
“tags”: []
}
],
“timeFrom”: null,
“timeShift”: null,
“title”: “Insulin History”,
“transparent”: true,
“type”: “natel-plotly-panel”,
“version”: 1
}
],
“refresh”: “2s”,
“schemaVersion”: 22,
“style”: “dark”,
“tags”: [],
“templating”: {
“list”: []
},
“time”: {
“from”: “now-30m”,
“to”: “now”
},
“timepicker”: {
“refresh_intervals”: [
“2s”,
" 5s”,
“10s”,
“30s”,
“1m”,
“5m”,
“15m”,
“30m”,
“1h”,
“2h”,
“1d”
]
},
“timezone”: “”,
“title”: “Meterbolic Real-time dashboard”,
“uid”: “2waiYmuZz”,
“version”: 15
}

Thanks for the details! Nothing special about your JSON, I tried to import it and I can edit the panels.

What browser are you using?

And what’s your problem exactly? You say you can click on the small arrow so you see it and what happen next? You can click on the edit link but it does nothing? Or you don’t see the edit link?

Do you have any error on your browser console? (before of after clicking on edit)

Thanks @agnestoulet1
It turns out that on Mac chrome (based browsers), the dropdown does not work but on Safari it works!

1 Like

I confirm the same bug with Google Chrome 84.0.4147.135 (Official Build) on Ubuntu Linux.

Same here, same Chrome, on Windows. I also get the same problem with (new) Edge 85. Here’s what I see:

As you can see, one of the edit options is present, the other is not.

This is running Grafana latest (Grafana v7.1.5 (9893b8c53d)) in Docker.

I am having this problem again now with the latest Chrome on Mac (Version 89.0.4389.82). When I click on the panel title or little down arrow, nothing happens. It works fine on Safari. * Grafana v7.3.4 (14c494085e)

Hello @shamimmirzai, here is the github issue related to this problem:

I would suggest checking the issue to see, when is the issue fixed.

1 Like

Zoom in or out your page to 100 percent scale, and you will be able to edit your panel again.
image image