Cannot create query - new Grafana installation

Hi.

I’ve just installed Grafana 6.1.2 on a Debian 9.8 server, with InfluxDB as the local data source.

I’ve managed to get Grafana to recognise the data source, but I am unable to create any queries.

The Home screen tells me I have installed Grafana and created my first Data Source - the next step it offers is to create a New Dashboard.

I click on New Dashboard, and get a screen with a “New Panel” containing three options - “Add Query”, “Choose Visualisation” and “Convert to Row”. None of this looks like the begineers’ guide documented at https://www.youtube.com/watch?v=sKNZMtoSHN4

If I click on “Add Query”, I get a grid display with four icons at the left, and a bar containing “Queries to” with “default” selected. I can change this to “InfluxDB” if I want to.

Over to the right of this bar are buttons “Add Query”, “Query Inspector” and a Question Mark. Clicking on any of these does absolutely nothing.

So, having created my data source (and I’ve confirmed with the “influx” command that it does indeed contain data), how do I get Grafan to show any of it?

Thanks,

Antony.

You should see the query form too


You will need some data in the db (perhaps you already have some) so you can select the metrics to be graphed in the query form

I’ve just had a breakthrough on this.

I decided to try looking at Grafana on my phone instead of my PC, simply
because my phone has a more up-to-date version of Firefox installed on it.

If I held my phone in portrait mode, I suddenly got the query fields to show
up.

Rotating to landscape made them disappear.

Portrait, they come back again…

So, I went back to my PC, and resized the browser window…

Anything below 635 pixels wide shows me the query fields. Anything wider than
that doesn’t show them. Height appears not to be a factor.

Is this worth a bug report (and if so, can someone point me at how to file it),
is it a known problem, or is there something I should adjust in a configuration
file to tell Grafana that I have a 1920x1080 display and I’d quite like to be
able to use it please?

Antony.

That is weird, I have never seen anything like that. It does switch into a different display mode on small screens but I see the query form whatever the size. You can submit an issue on the github site. In my experience issues are responded to within 24 hours or so.


or specifically https://github.com/grafana/grafana/issues

I tried v6.1.2 on firefox also on debian, and don’t see the influx query editor going away at any resolution (tried all the way to 2560 on a 2K display)

Changing the height can make the scrollbar appear, but I still can scroll down to see the query editor.

On the far right of the query if you select the “pencil” icon, it will toggle between raw mode and interactive mode:
image

interactive:
image

raw:

Can you take a screenshot it happening?