Cannot connect to grafana

So i’m running a grafana server on my local server at home, i used to be able to access it before but a few months ago it just stopped working and the port just completely died. I’ve tried updating my ssl certificates, restarting the server, checking over my config, using ufw to open up port 3000, restarting the grafana-server service and the webserver, but i’m just not able to access the port even on my local network.


What OS is running on that local server?

If Linux, have you tried this in terminal?

sudo systemctl status grafana-server

If Windows Server, did you go through all of these steps to ensure it’s running?

I’m running Debian 11, and have attached the output of the command.
Screenshot_3

It also seems to be destroying my cpu at all times.

I would check Grafana server logs first. Please use formatted text’s instead of images.

logger=settings t=2023-10-25T14:35:22.161394066+01:00 level=info msg="Starting Grafana" version=10.0.0 commit=81d85ce802 branch=HEAD compiled=2023-06-09T17:45:53+01:00
logger=settings t=2023-10-25T14:35:22.162391834+01:00 level=warn msg="\"sentry\" frontend logging provider is deprecated and will be removed in the next major version. Use \"grafana\" provider instead."
logger=settings t=2023-10-25T14:35:22.162489385+01:00 level=info msg="Config loaded from" file=/usr/share/grafana/conf/defaults.ini
logger=settings t=2023-10-25T14:35:22.162636368+01:00 level=info msg="Config loaded from" file=/etc/grafana/grafana.ini
logger=settings t=2023-10-25T14:35:22.162710582+01:00 level=info msg="Config overridden from command line" arg="default.paths.data=/var/lib/grafana"
logger=settings t=2023-10-25T14:35:22.162784957+01:00 level=info msg="Config overridden from command line" arg="default.paths.logs=/var/log/grafana"
logger=settings t=2023-10-25T14:35:22.162856546+01:00 level=info msg="Config overridden from command line" arg="default.paths.plugins=/var/lib/grafana/plugins"
logger=settings t=2023-10-25T14:35:22.162925534+01:00 level=info msg="Config overridden from command line" arg="default.paths.provisioning=/etc/grafana/provisioning"
logger=settings t=2023-10-25T14:35:22.162995558+01:00 level=info msg=Target target=[all]
logger=settings t=2023-10-25T14:35:22.163083469+01:00 level=info msg="Path Home" path=/usr/share/grafana
logger=settings t=2023-10-25T14:35:22.163151104+01:00 level=info msg="Path Data" path=/var/lib/grafana
logger=settings t=2023-10-25T14:35:22.163218376+01:00 level=info msg="Path Logs" path=/var/log/grafana
logger=settings t=2023-10-25T14:35:22.163288948+01:00 level=info msg="Path Plugins" path=/var/lib/grafana/plugins
logger=settings t=2023-10-25T14:35:22.16336764+01:00 level=info msg="Path Provisioning" path=/etc/grafana/provisioning
logger=settings t=2023-10-25T14:35:22.163436222+01:00 level=info msg="App mode production"
logger=sqlstore t=2023-10-25T14:35:22.164610628+01:00 level=info msg="Connecting to DB" dbtype=sqlite3
logger=migrator t=2023-10-25T14:35:22.248616221+01:00 level=info msg="Starting DB migrations"
logger=migrator t=2023-10-25T14:35:22.270579832+01:00 level=info msg="migrations completed" performed=0 skipped=485 duration=1.571375ms
logger=secrets t=2023-10-25T14:35:22.27517985+01:00 level=info msg="Envelope encryption state" enabled=true currentprovider=secretKey.v1
logger=plugin.loader t=2023-10-25T14:35:22.584337789+01:00 level=info msg="Plugin registered" pluginID=input
logger=query_data t=2023-10-25T14:35:22.595845566+01:00 level=info msg="Query Service initialization"
logger=live.push_http t=2023-10-25T14:35:22.605553576+01:00 level=info msg="Live Push Gateway initialization"
logger=ngalert t=2023-10-25T14:35:22.619298377+01:00 level=warn msg="Unexpected number of rows updating alert configuration history" rows=0 org=1 hash=not-yet-calculated
logger=infra.usagestats.collector t=2023-10-25T14:35:27.826866343+01:00 level=info msg="registering usage stat providers" usageStatsProvidersLen=2
logger=server t=2023-10-25T14:35:27.82713825+01:00 level=info msg="Writing PID file" path=/run/grafana/grafana-server.pid pid=268896
logger=provisioning.alerting t=2023-10-25T14:35:27.831299828+01:00 level=info msg="starting to provision alerting"
logger=provisioning.alerting t=2023-10-25T14:35:27.831414501+01:00 level=info msg="finished to provision alerting"
logger=modules t=2023-10-25T14:35:27.832001383+01:00 level=warn msg="No modules registered..."
logger=http.server t=2023-10-25T14:35:27.840582472+01:00 level=info msg="HTTP Server Listen" address=[::]:3000 protocol=https subUrl= socket=
logger=ngalert.state.manager t=2023-10-25T14:35:27.842679156+01:00 level=info msg="Warming state cache for startup"
logger=grafanaStorageLogger t=2023-10-25T14:35:27.846648171+01:00 level=info msg="storage starting"
logger=ngalert.state.manager t=2023-10-25T14:35:27.886742509+01:00 level=info msg="State cache has been initialized" states=0 duration=44.054322ms
logger=ticker t=2023-10-25T14:35:27.886985744+01:00 level=info msg=starting first_tick=2023-10-25T14:35:30+01:00
logger=ngalert.multiorg.alertmanager t=2023-10-25T14:35:27.887053561+01:00 level=info msg="starting MultiOrg Alertmanager"
logger=grafana.update.checker t=2023-10-25T14:35:27.93026621+01:00 level=info msg="Update check succeeded" duration=83.933512ms
logger=plugins.update.checker t=2023-10-25T14:35:27.946216972+01:00 level=info msg="Update check succeeded" duration=99.92901ms

Anyone know a fix?