Bad Gauge update over MQTT

Hey there, I am kinda new into Grafana. I Happyly built my first Dashboard. It contains some charts powered by a Influxdb, this is working fine so far. But I also have Gauges which are powered by MQTT. I am getting MQTT updates every second on the broker, but my grafana only updates every 10 seconds or so and most of the time it shows “No data”. What can I do about it?

Hey @mallo321123

I kinda had the same issue for some panel. I checked and it was because some value in my different fields are empty. Check if your base is okay.
Are you using influxDB V1 or V2? Which collector are you using?


I am using Influxdb V2 and my collector is Telegraf. But this doesn’t matter, because the influx part is working fine. I use two data sources for my Dashboard, I use the Influxdb only for the graphs. And for the gauges i use MQTT as a data source, because I thought it would be better

Since MQTT is not native to Grafana and I’ve never used it I’ll not be able to help you with that.
Why don’t you use your influx connection instead?

I think MQTT directly into grafana is less latency and does more data updates. What do you mean MQTT is not native? you can normaly add it as a data source

I mean that if you have a fresh install of Grafana, you have to install the MQTT plugin if you want to use it.

thats true, and this is a reason for you not to use it?

This could be a help with the refresh interval settings?

Thanks for the advice. I tried it, but it didn’t change anything

Hey, I found a solution, I Changed in the query options of the Gauge the “Max data points” value to 100000. Now the refresh rate is at a Second. Can you call this a Workaround?