AutoSizeInput Component in Grafana UI Lib. Bug

Hello Everybody,

I would like to use the AutoSizeComponent insead of Input component.
However, when I tried to use it, I got an error.

I got this error also in a brand new grafana project created using grafana toolkit. I followed the instructions of the Grafana Story Book.
Does the component has a bug or what am I doing wrong? Normally it is straightforward: just import the component from @grafana/ui and use it. Everything seems to be clear in the storybook.
What can be wrong? Any help is very appreciate!

Thank you very much in advance!


Hi @companymvms,

Thanks for opening this post.

Can you please point us to the URL link of the grafana toolkit? I am not an expert on this matter but will like to know what resources you used and might be able to point you in the right direction.

yes, thanks for replying.
The storybooks link as show above is: AutoSizeInput

So, if you create a new project using the grafana toolkit, as an example:

npx @grafana/toolkit plugin:create my-plugin-name

then add the component above, you will for sure get the same error as I got.

Thanks and sorry for the delay to replay it.