Auto-refresh does not work if "time picker" is hidden

Currently using 7.3.5 but have seen this with older versions as well (6.4.1, 7.1) - If I set the refresh interval to something like 1m or 5m and then hide the time picker my dashboard never refreshes. If I make the picker visible again then it works.

“timepicker”: {
“hidden”: true,
“refresh_intervals”: [
“1m”
]
},

Is there some other option related to this I am missing?

Hi, auto refresh functionality is part of the timepicker, so when the timepicker is hidden this functionality is disabled.

Thanks Alex for the reply. Not what I was hoping to hear but now I know.