APM integration (Datadog) no longer working as of today

I have verified that I can ship metrics when running k6 cloud locally.

Hey @leathej1,

We’re investigating the issue.

The issue is fixed and the DataDog integration in Cloud APM works properly now.

1 Like

No, I am still not seeing it.

Remove the "name" from ext.loadimpact.apm[0].metrics in your script.

Oh, that functionality is still in the works, I guess. Hmm… that means I have to change depending on whether I run my script locally or in cloud. Can’t we just continue to ignore it if not applicable?

I have removed name and the metrics are still not being pushed.

I have tested your same exact APM config with our api- and appKey with an script on the cloud and it works perfectly.

It did not make it to me, then. So, not perfectly.

I have also recreated the project, using the same script that I ran locally. The local execution is successfully sending data while the cloud execution is still not.

If you’re using __ENV variables directly on Cloud via Script Editor, they might not be replaced with their values.

I found the issue that causes your test run not to export metrics, and I am releasing a hotfix today.

The hotfix is released. Please test again.

k6 Cloud:


Azure Monitor:

Thanks very much!

1 Like