Alerting default configuration not taken into account

Hi there,

I need help with two configurations on alerts. I can’t tell if this is a misunderstanding on my part or a possible bug.

  • What Grafana version and what operating system are you using?
    Grafana v9.2.4

  • What are you trying to achieve?
    I want to change the default configuration defined in grafana.ini for [Alerting] error_or_timeout and [Alerting] nodata_or_nullvalues

  • How are you trying to achieve it?
    Change the value inside grafana.ini, then restart grafana.

  • What happened?
    Modifying values in the grafana.ini file is not taken into account.

  • What did you expect to happen?
    Unless I am mistaken, the values should be taken into account when creating a new alert by automatically setting the default values on this step.
    image
    But whatever the value defined in the grafana.ini, this value remains

  • “No Data” for nodata_or_nullvalues
  • “Error” for error_or_timeout
    It is indeed possible to make the modification manually during this step, but the default configuration does not seem to be taken into account.
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    No error displayed.

Moreover, it seems that there is a difference between the docs and the front.

nodata_or_nullvalues :

  • Docs : Options are alerting , no_data , keep_state , and ok . Default is no_data
  • Front : Options are alerting , no_data , and ok . Default is no_data

error_or_timeout :

  • Docs : Options are alerting ,keep_state . Default is alerting
  • Front : Options are alerting , error , and ok . Default is error

Grafana Docs source : Configure Grafana | Grafana documentation

Thank you in advance for your help !

Hi @rmacgi and welcome to the :grafana: Grafana Community forum!

Assumming you have uncommented each line of the grafana.ini, could you please copy paste the values for error_or_timeout, and nodata_or_nullvalues as they are in your current grafana.ini, or provide a screenshot ?

Hi @antonio.merello and thank you for your response.

I do not use the grafana.ini file directly because I am in a docker environment (Azure App service).

In my case I use configuration override with environment variables.

Azure App settings
image

Grafana settings (after override)
image

Other configurations use this method and are well taken into account.

Hi again @rmacgi and thanks for the info

We have managed to reproduce your scenario in a docker environment resulting in a similar behavior. This might be a valid issue. If so, we would also address the mismatch between the options for alerting in docs, .ini, and GUI

I will go ahead an report the issue to our Github repository Once it is open, I will share the link here.

Thank you

Thank you for your help @antonio.merello !

you are welcome @rmacgi !

here is the link to the issue on github

Hi! It looks like you are changing configuration for legacy alerting but the screenshot shows you using unified alerting. If you would like to change configuration for unified alerting then you can do so under [unified_alerting] instead of [alerting].